2006年03月30日

MySQLのサブクエリは4.1からですよ

今日はSQLがエラーになるのでなんでだろうと悩みました。

というのも
delete from tb1 where id in (select id form tb2)

というような、サブクエリを含むSQLを発行できなかったからです。

知らなかったのですが、こういうSQLはMySQL4.1系からしか有効でないそうです。
借りてるサーバーは4.0系でした・・・

気付くのに時間かかりすぎてしょんぼり(´・ω・`)


しょうがないので自力でselectして地道に消しました。
たぶん、ましな方法は他にもあると思いますが、これしか思いつかなかったので。



本当にこのタイトル通りかもしれません・・・(汗


posted by ケイ at 17:59| Comment(0) | TrackBack(0) | プログラム | このブログの読者になる | 更新情報をチェックする
この記事へのコメント
コメントを書く
お名前: [必須入力]

メールアドレス:

ホームページアドレス:

コメント:

この記事へのトラックバックURL
http://blog.seesaa.jp/tb/15813824
※ブログオーナーが承認したトラックバックのみ表示されます。
※言及リンクのないトラックバックは受信されません。

この記事へのトラックバック
×

この広告は1年以上新しい記事の投稿がないブログに表示されております。